Stats Delay
Incident Report for Deskmetrics
Resolved
Event backlog has cleared.
Posted about 1 year ago. May 24, 2017 - 01:52 PDT
Monitoring
Event backlog is clearing.
Posted about 1 year ago. May 24, 2017 - 01:39 PDT
Investigating
We are currently experiencing a stats delay.
Posted about 1 year ago. May 24, 2017 - 01:18 PDT