Maintenance Delays
Incident Report for Deskmetrics
Resolved
Maintenance has completed, thank you for your patience.
Posted over 1 year ago. Feb 06, 2017 - 15:00 PST
Monitoring
We are currently performing maintenance on the Deskmetrics infrastructure. You may experience some brief stats delays throughout the day.
Posted over 1 year ago. Feb 06, 2017 - 09:24 PST